using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@require (.+?)?(?:-->|\s)";
string input = @"<head>
<meta charset=""UTF-8"">
<title></title>
<!--@require a.css-->
<!--@require BOWER/jquery-->
<!--@require /build/bundle-->
<!--
@require bootstrap
@require bootstrap.css
@require bootstrap.font
-->
</head>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}