import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@require (.+?)?(?:-->|\\s)";
final String string = "<head>\n"
+ " <meta charset=\"UTF-8\">\n"
+ " <title></title>\n"
+ " <!--@require a.css-->\n"
+ " <!--@require BOWER/jquery-->\n"
+ " <!--@require /build/bundle-->\n"
+ " <!--\n"
+ " @require bootstrap\n"
+ " @require bootstrap.css\n"
+ " @require bootstrap.font\n"
+ " -->\n"
+ "</head>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}