re = /@require (.+?)?(?:-->|\s)/m
str = '<head>
<meta charset="UTF-8">
<title></title>
<!--@require a.css-->
<!--@require BOWER/jquery-->
<!--@require /build/bundle-->
<!--
@require bootstrap
@require bootstrap.css
@require bootstrap.font
-->
</head>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end