using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(2[0-4]|[01]?[0-9])$";
string input = @"-2
-1
0
1
2
3
04
5
6
07
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}