import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(2[0-4]|[01]?[0-9])$";
final String string = "-2\n"
+ "-1\n"
+ "0\n"
+ "1\n"
+ "2\n"
+ "3\n"
+ "04\n"
+ "5\n"
+ "6\n"
+ "07\n"
+ "8\n"
+ "9\n"
+ "10\n"
+ "11\n"
+ "12\n"
+ "13\n"
+ "14\n"
+ "15\n"
+ "16\n"
+ "17\n"
+ "18\n"
+ "19\n"
+ "20\n"
+ "21\n"
+ "22\n"
+ "23\n"
+ "24\n"
+ "25\n"
+ "26";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}