re = /^(2[0-4]|[01]?[0-9])$/m
str = '-2
-1
0
1
2
3
04
5
6
07
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end