use strict;
my $str = '-2
-1
0
1
2
3
04
5
6
07
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26';
my $regex = qr/^(2[0-4]|[01]?[0-9])$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}