import re
regex = re.compile(r"^(2[0-4]|[01]?[0-9])$", flags=re.MULTILINE)
test_str = ("-2\n"
"-1\n"
"0\n"
"1\n"
"2\n"
"3\n"
"04\n"
"5\n"
"6\n"
"07\n"
"8\n"
"9\n"
"10\n"
"11\n"
"12\n"
"13\n"
"14\n"
"15\n"
"16\n"
"17\n"
"18\n"
"19\n"
"20\n"
"21\n"
"22\n"
"23\n"
"24\n"
"25\n"
"26")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")