package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(2[0-4]|[01]?[0-9])$`)
var str = `-2
-1
0
1
2
3
04
5
6
07
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}