using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(START)|(<--)|(==:)).*?(?(1)END)(?(2)-->)(?(3):==)";
string input = @"Yo, START cool dude END
Hey, <-- my friend -->
Howdy, ==: partner :==";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}