// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(START)|(<--)|(==:)).*?(?(1)END)(?(2)-->)(?(3):==)").unwrap();
let string = "Yo, START cool dude END
Hey, <-- my friend -->
Howdy, ==: partner :==";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}