package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(START)|(<--)|(==:)).*?(?(1)END)(?(2)-->)(?(3):==)`)
var str = `Yo, START cool dude END
Hey, <-- my friend -->
Howdy, ==: partner :==`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}