$re = '/(?:(START)|(<--)|(==:)).*?(?(1)END)(?(2)-->)(?(3):==)/m';
$str = 'Yo, START cool dude END
Hey, <-- my friend -->
Howdy, ==: partner :==';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);