re = /(?:(START)|(<--)|(==:)).*?(?(1)END)(?(2)-->)(?(3):==)/m
str = 'Yo, START cool dude END
Hey, <-- my friend -->
Howdy, ==: partner :=='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end