const regex = /(?:(START)|(<--)|(==:)).*?(?(1)END)(?(2)-->)(?(3):==)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(START)|(<--)|(==:)).*?(?(1)END)(?(2)-->)(?(3):==)', 'gm')
const str = `Yo, START cool dude END
Hey, <-- my friend -->
Howdy, ==: partner :==`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}