#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^0-9a-z]?)(?<name>@(?!(qwerty))(\w+\.{0,1}){2,}\w+)"
Local $sString = "@a " & @CRLF & _
"@ab " & @CRLF & _
"@abc " & @CRLF & _
"a@xyz " & @CRLF & _
"!@ijmn,@123 " & @CRLF & _
"0@321 " & @CRLF & _
"@1a2b " & @CRLF & _
"@qwerty" & @CRLF & _
"" & @CRLF & _
"@abc.a " & @CRLF & _
"@stu..test " & @CRLF & _
"_@nmp " & @CRLF & _
"@x.yz.@klm " & @CRLF & _
"@.1a2b " & @CRLF & _
".@2c3d."
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)