$re = '/([^0-9a-z]?)(?<name>@(?!(qwerty))(\w+\.{0,1}){2,}\w+)/m';
$str = '@a
@ab
@abc
a@xyz
!@ijmn,@123
0@321
@1a2b
@qwerty
@abc.a
@stu..test
_@nmp
@x.yz.@klm
@.1a2b
.@2c3d.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;