import re
regex = re.compile(r"([^0-9a-z]?)(?<name>@(?!(qwerty))(\w+\.{0,1}){2,}\w+)", flags=re.MULTILINE)
test_str = ("@a \n"
"@ab \n"
"@abc \n"
"a@xyz \n"
"!@ijmn,@123 \n"
"0@321 \n"
"@1a2b \n"
"@qwerty\n\n"
"@abc.a \n"
"@stu..test \n"
"_@nmp \n"
"@x.yz.@klm \n"
"@.1a2b \n"
".@2c3d.")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)