re = /([^0-9a-z]?)(?<name>@(?!(qwerty))(\w+\.{0,1}){2,}\w+)/m
str = '@a
@ab
@abc
a@xyz
!@ijmn,@123
0@321
@1a2b
@qwerty
@abc.a
@stu..test
_@nmp
@x.yz.@klm
@.1a2b
.@2c3d.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result