import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^0-9a-z]?)(?<name>@(?!(qwerty))(\\w+\\.{0,1}){2,}\\w+)";
final String string = "@a \n"
+ "@ab \n"
+ "@abc \n"
+ "a@xyz \n"
+ "!@ijmn,@123 \n"
+ "0@321 \n"
+ "@1a2b \n"
+ "@qwerty\n\n"
+ "@abc.a \n"
+ "@stu..test \n"
+ "_@nmp \n"
+ "@x.yz.@klm \n"
+ "@.1a2b \n"
+ ".@2c3d.";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}