using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^0-9a-z]?)(?<name>@(?!(qwerty))(\w+\.{0,1}){2,}\w+)";
string substitution = @"";
string input = @"@a
@ab
@abc
a@xyz
!@ijmn,@123
0@321
@1a2b
@qwerty
@abc.a
@stu..test
_@nmp
@x.yz.@klm
@.1a2b
.@2c3d.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}