using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(?:[_-]$|_ | _))(?:[a-zA-Z][\w -]*)?$";
string input = @" // Match
A
HelloWorld
Hello_-World
Hello_World_1
He110_W0rld
Hello - World
Hello-World
// doesn't match
Hello _World
Hello_ World
Hello _ World
_HelloWorld";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}