const regex = /^(?!.*(?:[_-]$|_ | _))(?:[a-zA-Z][\w -]*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(?:[_-]$|_ | _))(?:[a-zA-Z][\\w -]*)?$', 'gm')
const str = ` // Match
A
HelloWorld
Hello_-World
Hello_World_1
He110_W0rld
Hello - World
Hello-World
// doesn't match
Hello _World
Hello_ World
Hello _ World
_HelloWorld`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}