re = /^(?!.*(?:[_-]$|_ | _))(?:[a-zA-Z][\w -]*)?$/m
str = ' // Match
A
HelloWorld
Hello_-World
Hello_World_1
He110_W0rld
Hello - World
Hello-World
// doesn\'t match
Hello _World
Hello_ World
Hello _ World
_HelloWorld'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end