import re
regex = re.compile(r"^(?!.*(?:[_-]$|_ | _))(?:[a-zA-Z][\w -]*)?$", flags=re.MULTILINE)
test_str = (" // Match\n"
"A\n"
"HelloWorld\n"
"Hello_-World\n"
"Hello_World_1\n"
"He110_W0rld\n"
"Hello - World\n"
"Hello-World\n\n"
" // doesn't match\n"
"Hello _World\n"
"Hello_ World\n"
"Hello _ World\n"
"_HelloWorld")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")