import Foundation
let pattern = #"^(?!.*(?:[_-]$|_ | _))(?:[a-zA-Z][\w -]*)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
// Match
A
HelloWorld
Hello_-World
Hello_World_1
He110_W0rld
Hello - World
Hello-World
// doesn't match
Hello _World
Hello_ World
Hello _ World
_HelloWorld
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)