import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*(?:[_-]$|_ | _))(?:[a-zA-Z][\\w -]*)?$";
final String string = " // Match\n"
+ "A\n"
+ "HelloWorld\n"
+ "Hello_-World\n"
+ "Hello_World_1\n"
+ "He110_W0rld\n"
+ "Hello - World\n"
+ "Hello-World\n\n"
+ " // doesn't match\n"
+ "Hello _World\n"
+ "Hello_ World\n"
+ "Hello _ World\n"
+ "_HelloWorld";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}