using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^)]*\)";
string input = @"here is some normal text (this comment should be removed) that should not be deleted
(comment by itself on a line)
(comment starting) but then some text.
random start of string ( here is a comment
spanning two lines ) even with some text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}