import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^)]*\\)";
final String string = "here is some normal text (this comment should be removed) that should not be deleted\n"
+ "(comment by itself on a line)\n"
+ "(comment starting) but then some text.\n"
+ "random start of string ( here is a comment\n"
+ "spanning two lines ) even with some text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}