$re = '/\([^)]*\)/m';
$str = 'here is some normal text (this comment should be removed) that should not be deleted
(comment by itself on a line)
(comment starting) but then some text.
random start of string ( here is a comment
spanning two lines ) even with some text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);