# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:dames|heren|schoenen us)\s+([a-z]*\s*)(?:([a-z]+)[\s\/]*$|\D*(\d+)(?:[\s\/]*$|(\s+\\/\s+)\D*(\d+).*$))/$1$2$3$4$5/igm;t' <<< "Schoenen US 30 /
Dames US 30 /
Dames US w30 /
Heren US w30 / L34
Dames US L /"