const regex = /^(?:dames|heren|schoenen us)\s+([a-z]*\s*)(?:([a-z]+)[\s/]*$|\D*(\d+)(?:[\s/]*$|(\s+\/\s+)\D*(\d+).*$))/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:dames|heren|schoenen us)\\s+([a-z]*\\s*)(?:([a-z]+)[\\s\/]*$|\\D*(\\d+)(?:[\\s\/]*$|(\\s+\\\/\\s+)\\D*(\\d+).*$))', 'igm')
const str = `Schoenen US 30 /
Dames US 30 /
Dames US w30 /
Heren US w30 / L34
Dames US L /`;
const subst = `$1$2$3$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);