import re
regex = re.compile(r"^(?:dames|heren|schoenen us)\s+([a-z]*\s*)(?:([a-z]+)[\s/]*$|\D*(\d+)(?:[\s/]*$|(\s+\/\s+)\D*(\d+).*$))", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("Schoenen US 30 / \n"
"Dames US 30 / \n"
"Dames US w30 / \n"
"Heren US w30 / L34\n"
"Dames US L /")
subst = "$1$2$3$4$5"
result = regex.sub(subst, test_str)
if result:
print(result)