re = /^(?:dames|heren|schoenen us)\s+([a-z]*\s*)(?:([a-z]+)[\s\/]*$|\D*(\d+)(?:[\s\/]*$|(\s+\/\s+)\D*(\d+).*$))/im
str = 'Schoenen US 30 /
Dames US 30 /
Dames US w30 /
Heren US w30 / L34
Dames US L /'
subst = '$1$2$3$4$5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result