import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:dames|heren|schoenen us)\\s+([a-z]*\\s*)(?:([a-z]+)[\\s/]*$|\\D*(\\d+)(?:[\\s/]*$|(\\s+\\/\\s+)\\D*(\\d+).*$))";
final String string = "Schoenen US 30 / \n"
+ "Dames US 30 / \n"
+ "Dames US w30 / \n"
+ "Heren US w30 / L34\n"
+ "Dames US L /";
final String subst = "$1$2$3$4$5";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}