#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "-([^-\s]+)"
Local $sString = "Some Text" & @CRLF & _
"Another Text" & @CRLF & _
"-something/3443/kk-somethingelse/111/333/zz" & @CRLF & _
"-text/ff/33/33/zz" & @CRLF & _
"Text Text" & @CRLF & _
"Text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")