import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-([^-\\s]+)";
final String string = "Some Text\n"
+ "Another Text\n"
+ "-something/3443/kk-somethingelse/111/333/zz\n"
+ "-text/ff/33/33/zz\n"
+ "Text Text\n"
+ "Text";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}