// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"-([^-\s]+)").unwrap();
let string = "Some Text
Another Text
-something/3443/kk-somethingelse/111/333/zz
-text/ff/33/33/zz
Text Text
Text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}