package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`-([^-\s]+)`)
var str = `Some Text
Another Text
-something/3443/kk-somethingelse/111/333/zz
-text/ff/33/33/zz
Text Text
Text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}