re = /-([^-\s]+)/
str = 'Some Text
Another Text
-something/3443/kk-somethingelse/111/333/zz
-text/ff/33/33/zz
Text Text
Text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end