# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/==(.*?)==/<span class="highlight">\1<\/span>/gms;t' <<< "Edit the ==Expression=
== & T==sa==ext to see matches."