const regex = /==(.*?)==/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('==(.*?)==', 'gms')
const str = `Edit the ==Expression=
== & T==sa==ext to see matches.`;
const subst = `<span class="highlight">\1</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);