import Foundation
let pattern = #"==(.*?)=="#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
Edit the ==Expression=
== & T==sa==ext to see matches.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<span class="highlight">\1</span>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)