#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)==(.*?)=="
Local $sString = "Edit the ==Expression=" & @CRLF & _
"== & T==sa==ext to see matches."
Local $sSubst = "<span class="highlight">\1</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)