import re
regex = re.compile(r"==(.*?)==", flags=re.MULTILINE | re.DOTALL)
test_str = ("Edit the ==Expression=\n"
"== & T==sa==ext to see matches.")
subst = "<span class=\"highlight\">\\1</span>"
result = regex.sub(subst, test_str)
if result:
print(result)