using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"==(.*?)==";
string substitution = @"<span class=""highlight"">\1</span>";
string input = @"Edit the ==Expression=
== & T==sa==ext to see matches.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}