const regex = /.*<B>(.*)<\/B> = (.*)<BR><B>(.*)<\/B> = (.*)<BR><B>(.*)<\/B> = (.*)<BR><B>(.*)<\/B> = (.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*<B>(.*)<\\\/B> = (.*)<BR><B>(.*)<\\\/B> = (.*)<BR><B>(.*)<\\\/B> = (.*)<BR><B>(.*)<\\\/B> = (.*)$', 'gm')
const str = `Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> =
Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Kultura</B> = <BR><B>Kul</B> = `;
const subst = `$1 - $2\n$3 - $4\n$5 - $6\n$7 - $8`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);