$re = '/.*<B>(.*)<\/B> = (.*)<BR><B>(.*)<\/B> = (.*)<BR><B>(.*)<\/B> = (.*)<BR><B>(.*)<\/B> = (.*)$/Um';
$str = 'Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> =
Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Kultura</B> = <BR><B>Kul</B> = ';
$subst = "$1 - $2\n$3 - $4\n$5 - $6\n$7 - $8";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;