use strict;
my $str = 'Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> =
Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Kultura</B> = <BR><B>Kul</B> = ';
my $regex = qr/.*<B>(.*)<\/B> = (.*)<BR><B>(.*)<\/B> = (.*)<BR><B>(.*)<\/B> = (.*)<BR><B>(.*)<\/B> = (.*)$/mp;
my $subst = '$1 - $2\\n$3 - $4\\n$5 - $6\\n$7 - $8';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";