package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?Um)<BR><B>(.*)<\/B>|= ([\w\s]+?|)$|= ([\w\s]+?|)`)
var str = `Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Desc</B> = <BR><B>Kultura</B> = sssssss
Unknown Area Type<BR><BR><B>NAME</B> = Корочанский район<BR><B>NAME</B> = Корочанский район<BR><B>FEATUREID</B> = 11<BR><B>Kultura</B> = <BR><B>Kul</B> = zzzzzzzzz dstset
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}